Knowledge Explorer Plugin

Hi @sam

Thanks very much for your reply.

Yes, we do have categories settings as last post shows. If not, Categories count in screenshot of my last post will be empty.

I found another site within this thread also has this issues. @
see at Hiveeyes

And both of us is using Discourse 2.4.0.beta. (beta8 & beta9)

I don’t figure out why Global Legal Empowerment Network Community Discussions don’t suffer this issue. Maybe his site has special settings? (Beta9)

Best Regards,
Lanco

Can you try safe mode? Looks like you have alot going on there and I suspect a conflict with another plugin or theme customization. It could also be related to language localization.

Aside: what is that margin notes plugin? That is pretty neat!

Update… your problem could be related to the content. Try it without oneboxed content or images and see if you can get it working at all. I did have problems in the past with embedded youtube videos but I think that has since been fixed.

4 Likes

Hi Tobias,

Thank you to point out onebox. I will have a test.

:face_with_monocle: :open_mouth: Which margin notes plugin do you interest? I don’t realize I’ve shown that thing in my screenshots.

Our community is bbs.marginnote.cn and forum.marginnote.com . If you found anything interesting. I’m willing to share with you.

Update: According to my test. An extremely simple post also has the issue.

Now I’m trying rebuild discourse with less plugin.

Best Regards,
Lanco

1 Like

No need - just use safe mode at /safe-mode and you can choose to see the site without plugins and theme customizations.

I just rebuild app only keep one plugin, K. Explorer…But succeed to show contents. Now I’m working on test which one conflicts.

Lanco

2 Likes

Found one conflict:

No others. Just QA plugin conflicts. No matter how I change the QA settings, only if I disable it, the K. Explorer plugin show contents.(Even the related categories is not QA enabling.)

Our forum has one catalog based on QA plugin. And it already has many posts in. It’s hard for me to abandon QA plugin, Hope lovely author could fix this. @justindirose And happy new year, sorry for disturb you!

Lanco

1 Like

Nice job troubleshooting! This may also be a QA plugin issue. If it is, @angus and his pavilion colleagues would no doubt appreciate a bug report at Bug Report.

1 Like

Indeed this specific topic does not render there. Thanks for spotting this! However, all others seem to work flawlessly, right?

Maybe an issue with the solved plugin?

Generally, this plugin works pretty well but it is also still fairly new, so we can expect there to be some kinks. Meanwhile holidays and lifestyle changes :baby_bottle: for the plugin creator, so we have to be patient. :wink:

I made a list of confictions:

Hard Reject (Must disable)

May cause loadinng problems if enable for related category:

  • Vote (First time of loading)
  • Solved (Everytime of loading)

Sir, I’m not sure is there any other loading issues in your site. @amotl
Please ensure your KE related categories have disabled these plugins. :grimacing:

List of ensuring to be fine:

Lanco

2 Likes

The slug can change easily, whereas the id will not. Not to mention we’d have to do a dance looking up the category by slug versus the id which I wanted to avoid.

@amotl are you talking about the onebox for the link? I’ll have to see if that’s something we can handle in this context. I’m not certain if it is.

I will say that KE is not designed to be a canonical source of information; that’s what the actual topic or category is for. I recommend linking to the original versus the KE view, which is meant only for exploration and quick reference.

This may be dependent on how DiscoTOC looks for elements in the code. I’ll have a look at some point here.

I’m assuming this is because the post widgets are being decorated in these plugins. I’ll have to see if this can be accounted for in the plugin, or if modifications need to be made elsewhere.

Please be aware I’m still on part-time leave, so these fixes may take some time.

6 Likes

@Lanco_Azure – I just tried running these together for conflicts and I cannot reproduce. All plugins and core are on latest. Can you ensure you’re on the latest version of Discourse and the plugin?

6 Likes

It’s not quite the OneBox I am referring to here, but more the caption for the link. KE just renders “Hiveeyes”, while usually link captions are derived from the resource’s title.

Sure, thanks for looking into this already. Please enjoy your time!

1 Like

Dear Justin
There is something wrong when i enter chinese, please look the under pic, i can’t enter chinese normally
discourse-knowledge
Thanks.

@joffreyjaffeux I honestly have no idea what would be causing the above issue with typing in Chinese – any suggestions?

I guess this is because this value comes from queryParam and as such probably goes through some url encoding ?

@aksoforever Thanks for reporting that – I’m copying Unicode characters into the search box and they are working just fine. Can you provide exact repro steps, including what browser and OS you’re using?

4 Likes

copy is good, it works for chinese,
Just can’t input Chinese normally, discourse will soon input letters before I input Chinese charactersi have try different browsers, chrome, opera, the same.
my os is win 10 chinese
Discourse Meta this website is the same.

5 Likes

Just confirming, our normal search box at the top works fine?

4 Likes

yes, it works fine every time.
thanks Sam and Justin.

4 Likes