Set up Reply via Email Support ✉

I forwarded your advice to our email guy and he said it wouldn’t work because we already use Google Apps to provide our @domain.com email addresses (and at $6/month we’re not particularly keen on taking on more of them). Is he right?

1 Like

In this case the sub-domain reply.my-discourse-site.com can use a completely different provider and setup when compared to the domain my-discourse-site.com.
So you “could” use any standard hosting just for MX mail exchange (receipt) on just that sub-domain.

If you are actually paying for “Google Apps for Work” (not the legacy free edition of Google Apps) you can configure mail to forward (to the free Gmail account) for free.

You don’t even need a sub-domain so instead of:
replies+%{reply_key}@reply.my-discourse-site.com
you could go with:
replies+%{reply_key}@my-discourse-site.com

  1. Login as a domain admin https://admin.google.com/
  2. Select “Apps” >“Google Apps” > “Gmail”
  3. Select “Advanced settings >” (near the bottom)
  4. Select “Default routing” at the top
  5. Select “Add Setting”
  6. Setup the setting as follows:

    That regular expression is ^replies\+[^@]+@
    If you have multiple domains in your Google Apps for Work account you might want to include the domain qualifier on the end of that expression (remember to escape you periods \.)
  7. Save

That will then forward that mail elsewhere for free without requiring payment for an additional Google Apps for Work user.

11 Likes

No, I think you still want two separate settings. The reply by email address is the template that will be used to generate the return address on outgoing mail, and alternative reply by email addresses is for any other addresses you want recognised as reply addresses for incoming e-mail. As @pfaffman said, you use the alternatives list when you change addresses for some reason, and don’t want new replies people make just after the switch (which will go to the old address, the one that was in the mail they received) to be thrown out.

8 Likes

Can you provide some examples? I am not quite following this

(emphasis added) Doh! So that’s why there are two. :slight_smile:

Fooled you, @zogstrip!

I used to get mail sent to someaddress@oldforum.com. Now I want to use anotheraddress@newforum.com. I don’t messages sent in reply to those old emails with the old address to bounce or otherwise not work.

3 Likes

Oh my… :blush:

Hopefully @mpalmer is here to save us all! :heart_eyes:

Maybe we should change the name of that setting so that it’s not confusing?

2 Likes

I recently had a mail change.

Does that mean i have to:

  • update that field with the old address template
  • forward all mail from the old account to the new account so it gets polled

Problem I have is forwarding email from the old account gets rejected once it passes through the new account with:

Something has gone wrong. Perhaps this topic was closed or deleted while you were looking at it?

An excerpt of the headers on the rejected email include:

From: Lucee Lang <lucee.lang.discourse@gmail.com>
To: hello@lucee.org
Message-ID: <CANfgq1VLZfK5P+hx7=LS3UJfY5QEkmY4v7ttZ4-cgJThYBHJAA@mail.gmail.com>
In-Reply-To: <CAOnx9sCiAX6W6OAgyL-LTcDpAryS_6JR1ipBBPM=5MBB0zBbvw@mail.gmail.com>
References: <topic/401@lang.lucee.org>
 <topic/401/1678@lang.lucee.org>
 <topic/401/1680@lang.lucee.org>
 <CAOnx9sCiAX6W6OAgyL-LTcDpAryS_6JR1ipBBPM=5MBB0zBbvw@mail.gmail.com>
Subject: Fwd: [lucee-lang] LAS Board: 2017 Week 08 Minutes

Where the following changes were made:

Has the change in domain for the forum basically kaiboshed the effort to change the email account?

Raghav, I’m seeing the same issue. I’ve got a dedicated SMTP server setup to send outgoing email but it isn’t doing a DKIM sign on the emails and after tracking it down it seems that discourse is doing exactly what you mentioned, it’s setting the reply-to address (in this case the gmail plus address) in the from header causing the server to skip the DKIM signature which is then causing it to get flagged as spam.

When analyzing the eMail I get the following from a server for a SPF failure:

Sender is not authorized by default to use ‘my.discussion+verp-53aaf8307a0067b9fe202ceee1166fc5@gmail.com’ in ‘mfrom’ identity

Did you figure out how to solve it or why it’s happening?

@Json_Blob can you elaborate what the issue was and how you fixed it?

1 Like

I am getting the same issue:

Sender is not authorized by default to use ‘community+verp-53aaf8307a0067b9fe202ceee1166fc5@youngfoodies.co.uk’ in ‘mfrom’ identity

I have tried using a generic @gmail.com address and a gsuit address that is tied to the same domain that discourse is running on (community.youngfoodies.co.uk)

Mail-tester flags this as spam and a percentage of our forum members also receive it in the spam.

Whats the best way to ensure discourse emails are not flagged as spam when using the verp reply to email address?

Many Thanks

1 Like

As a note, if you have two factor authentication enabled, you can generate an App password for discourse and use it in the Discourse pop3 email password setting without having to enable the Access from less secure apps option in GMail.

6 Likes

Has anything happened in this regard?
@JpMaxMan and @andreabedini have u tried to use mailgun somehow?

1 Like

I tried to set this up with a contact form on our website sending the email. It sets the “reply-to email address” to whatever people fill in on the form, and the “from name” is also set to the name field on the form. But the “from address” is our site’s email address.

The problem is that the site looks at the from address instead of the reply-to address, so all form submissions end up getting assigned to one staging account, even though they have different names and reply to addresses, because they have the same from address.

Is there any way to set this up so that a form submission turned into an email could create accounts correctly? I’m afraid if I set the “from address” to the address submitted in the form that the email will get blocked.

Hi, I’ve set up the reply by email feature on my forum. I use gmail.
It works well, however the emails on the server aren’t removed:


This setting is checked:
image

Am I missing something?

I follow this instruction, but it not fix my configure.
Could you help me to do it?

Did you enable access from less secure apps on your Google/Gmail account? Did it make any difference?

What help do you want?

A gmail problem is not a Discourse problem. There is a lot of help, tutorials and videos about how to use gmail features:
https://support.google.com/accounts/answer/6010255?hl=en

4 Likes

Found it: Start a New Topic via Email ✉

3 Likes

Can I ask what is the intented purpose of the alternative_reply_by_addresses? How do they it differ from reply_by_adress?

I think it’s mostly too user if you change the address and want to continue to support the old address for a time. I think that if you don’t know what it’s for you don’t need it

1 Like

Excellent, that’s precisely my use case. :grin: Had to change my email config this week, which is always a scary operation. :scream:

1 Like

Hi,

I setup and working greatly but if user reply via mail Discourse post user mail in post. Eg. write public user mail x@y.com

How can i hide?

Thanks.