Beginners Guide to Install Discourse on Ubuntu for Development

dev-install

(Sam Saffron) #215

My guess, redis is not running on your machine, or it is running on a custom port.


(Joshua Moore) #216

Do I need redis running on the Win 10 side? I am setting this up on Win 10 for development (Beginners Guide to Install Discourse on Windows 10 for Development).

Any idea on how I would find if it is running on a custom port? I believe redis is running since I get this:

redis-cli ping
PONG


(Sam Saffron) #217

Is that the same cli you are using to run migrate?


(Joshua Moore) #218

Yes I believe it is. How best can I confirm that?


(Claudiu) #219

I got this error while running the first command:

Fetching: bundler-1.16.3.gem (100%)
bundler’s executable “bundle” conflicts with /root/.rbenv/versions/2.5.1/bin/bundle
Overwrite the executable? [yN] ERROR: Error installing bundler:
“bundle” from bundler conflicts with /root/.rbenv/versions/2.5.1/bin/bundle
failed

Should I install bundler with an apt install or?


(Blake Erickson) #220

Which command specifically?

You can just run gem install bundler to install bundler, but according to your output it is already installed which is why there is a conflict. Maybe they are different version of bundler? bundler --version will show the current version installed, maybe it is different than 1.16.3?

Looks like you should just hit y and upgrade bunder:


(Claudiu) #221

I installed it with gem install and it seems to be working. Thanks for the help, @blake


(Sora &\) #222

Hello, i get this error when create user:

huynhthai824@UEH:~$ sudo -u postgres createuser -s huynhthai824
[sudo] password for huynhthai824:
createuser: could not connect to database postgres: could not connect to server: No such file or directory
Is the server running locally and accepting
connections on Unix domain socket “/var/run/postgresql/.s.PGSQL.5432”?
huynhthai824@UEH:~$

How do i continue?

I restart postgres and i solve this :slight_smile:


(Sora &\) #223

When i run this command

i get error

No connection to db, unable to retrieve site settings! (normal when running db:create)
rake aborted!
Errno::EINVAL: Invalid argument

How i continue?

I run Ubuntu on Window 10 store, so when i test Discourse, i will check in browse’s window 10?


#225

If you’re installing on Windows 10 subsystem for Linux then don’t you want this? Seems like there are different steps for database setup:


(Daniel Hollas) #227

Awesome guide, worked like a charm! :heart:

…except, don’t you need an extra step to install nodejs dependencies? Specifically, to run JS tests using qunit, I had to run:

npm install

(Arpit Jalan) #228

I updated the linux install script to install Node.js and svgo library. PR welcome for further improvements. :slight_smile:


(MorphZan) #229

Good Day

I have installed a fresh Ubuntu Server 18.04
I have run all the updates, rebooted.

Ran the command:

bash <(wget -qO- https://raw.githubusercontent.com/techAPJ/install-rails/master/linux)

It gets to this portion and it just sits here doing nothing - is there anything I can do from here or is it stuck permanently…

18


(Arpit Jalan) #230

Installing ruby takes time … maybe wait for ~20 mins.


(MorphZan) #231

Patience !!! Something im learning!!! :laughing:


(MorphZan) #232

After running this command:

bundle exec rake autospec

I am now stuck as follows, I am patiently waiting as suggested before but should I be concerned with the failures?:


(Arpit Jalan) #233

I need to look into why those tests are failing. In the meantime you can abort the rspec command and start using your local Discourse instance for development. If you reached to that step, your setup should be fine.


(Gerhard Schlager) #234

You need to install Imagemagick 7.


(MorphZan) #235

Going to continue then from here


(MorphZan) #236

Thank you for this have done so as well