Beginners Guide to Install Discourse on Ubuntu for Development

:warning: This guide covers installation instructions in development environment, for a production guide see: How to install Discourse in production (Discourse official install / standard install)

Ubuntu 22.04 warning for early adopters

This section added by @pfaffman 22.05.16 and should one day be wrong and the suggestion unnecessary.

NOTE: This won’t work for Ubuntu 22.04 just yet. If you are forced to use 22.04 (I was using Pop! OS), see Failed to build ruby 2.7.5 on ubuntu 22.04 · Discussion #1940 · rbenv/ruby-build · GitHub for how to compile a compatible version of openssl.

End of @pfaffman additions.

So you want to set up Discourse on Ubuntu to hack on and develop with?

We’ll assume that you don’t have Ruby/Rails/Postgres/Redis installed on your Ubuntu system. Let’s begin!

Although this guide assumes that you are using Ubuntu, but the set-up instructions will work fine for any Debian based distribution.

:exclamation: Depending on what version of Ubuntu/Debian you’re using to install Discourse, you may want to review: Notes about Installing Discourse on Ubuntu 20.04

Install Discourse Dependencies

As regular user run this script in terminal, to setup Rails development environment:-

bash <(wget -qO-

This will install following new packages on your system:

In case you have any of this package pre-installed and don’t want to run entire script, see the script and pick the packages you don’t have currently installed. The script is fine-tuned for Discourse, and includes all the packages required for Discourse installation.

Now that we have installed Discourse dependencies, let’s move on to install Discourse itself.

Clone Discourse

Clone the Discourse repository in ~/discourse folder:

git clone ~/discourse

~ indicates home folder, so Discourse source code will be available in your home folder.

Setup Database

Create role with the same name as your ubuntu system username:

sudo -u postgres createuser -s "$USER"

Bootstrap Discourse

Switch to your Discourse folder:

cd ~/discourse

Install the needed gems

source ~/.bashrc
bundle install

Now that you have successfully installed gems, run these commands:

bundle exec rake db:create 
bundle exec rake db:migrate
RAILS_ENV=test bundle exec rake db:create db:migrate

Try running the specs:

bundle exec rake autospec

All the tests should pass.

Start rails server:

bundle exec rails server

You should now be able to connect with your Discourse app on http://localhost:3000 - try it out!

Starting with Discourse 2.5+ EmberCLI is required in development and these additional steps will be required:

In a separate terminal instance, navigate to your discourse folder (cd ~/discourse) and run:


You should now be able to navigate to http://localhost:4200 to see your local Discourse installation.

Create New Admin

To create a new admin, run the following command:

RAILS_ENV=development bundle exec rake admin:create

Follow the prompts, and a new admin account will be created.

Configure Mail

Run MailHog:


Congratulations! You are now the admin of your own Discourse installation!

Happy hacking! And to get started with that, see Beginner’s Guide to Creating Discourse Plugins.

Beginners Guide to Install Discourse on Windows 10 for Development
HOWTO Set up a development environment using vagrant (Ubuntu guide)
Docker setup for development
Share your Discourse dev setup
Discourse Development Contribution Guidelines
Discourse as Your First Rails App
Why is my dev server not showing me uploaded images in Topics?
Install Discourse on Ubuntu for Development
Can't set up dev environment due to cppjieba_rb failing to install
How to open via internal IP?
Moderation Tools
Jhead and svgo errors while running specs
Rspec failing to load when using the official beginners guide
Not receiving Activation Email
Export only database data Postgres (for users, posts and topics)
How do I set up a local Discourse Development Environment?
How to create new user with verified email in development mode?
Issue in setup discourse on ubuntu server
Unable to create Vagrant local installation
Installing problem - bundle install
How to get a docker image of discourse using bash on windows 10?
Attachment filename not set on download
[PAID] Import from Legacy Postgres DB
Dev Category sidebar
How to add a new language
Discourse Server logs show DB queries when I run the server
Using the Discourse API Ruby Gem
Does Gemfile need to include svg?
Does Gemfile need to include svg?
Find app.yml on unsupported-install
Setting up Discourse for development on Fedora Linux
Database wont migrate Discourse
I want to build a debug version of discourse
How To Use Screen To Bootstrap A Development Install (Ubuntu)
Can I install discourse on my local machine
How to reset discourse on dev mode? (w/o docker)
Migrating from Ning to Discourse
Beginners Guide to Install Discourse on Windows 10 for Development
Nodebb to Discourse
Beginners Guide to Install Discourse on Windows 10 for Development
Beginners Guide to Install Discourse on Windows 10 for Development
RSpec search_spec.rb RateLimiter LimitExceeded problems
Discourse as Your First Rails App
Issue with vagrant version following the dev guide
NULL first_visited_at dates in the topic_users table
Multiple instances. Visiting the second instance signs out the logged in account on the running instance
Can't run my Discourse locally
I want to install a plugin for development, what should I do?
Mini_racer installation issues on ubuntu vagrant (OSX)
Bundle exec rake fails
Vbulletin 4 import -
Hello from Gitpod! (installing on google cloud + automated dev setup)
How to Install Discourse on LocalHost in Windows?
Migration from Yahoo! Groups
Does the forum for development start up 24 hours*?
Two issues: Are they related to sidekiq? uninitialized constant Jobs::Jobs ::Scheduled (Discourse Newbie)
Bitnami Discourse VM on Virtualbox + SMTP mail-server for testing
How to allow customs hosts in development mode
Help with setting up discourse An error occurred while installing xorcist (1.1.2), and Bundler cannot continue
Any interest in Podman?
Beginners Guide to Install Discourse for Development using Docker
Bundler cannot continue due installation error of mini_racer 0.4.0
How to setup discourse in my local for development?
How might we better structure #howto?
Please help, how do I install Discourse on macOS?
How might we better structure #howto?
Can't reach Discourse server in VM from Host
Importing / migrating MyBB to Discourse
Images are not being populated in discourse
How to install Discourse locally?
Beginner's Guide to Creating Discourse Plugins Part 1: Creating a basic plugin
Discourse Local setup
Is this correct? How long to install dev Version?
Overriding user_guardian.rb in a plugin (no fork necessary!)
Overriding user_guardian.rb in a plugin (no fork necessary!)
Importing / migrating from Kunena 3
Importing / migrating Phorum to Discourse
Importing / migrating MyBB to Discourse
Importing / migrating from FluxBB
Importing / migrating PunBB to Discourse
Importing / migrating NodeBB (MongoDB) to Discourse
Importing / migrating from vBulletin 4
Importing / migrating NodeBB (Redis) to Discourse
Importing / migrating from phpBB3
How Sam's Windows development environment is configured
Site setting is different Every time on Ubuntu development installation
Problems with understanding the development of Discourse
How do I change the address in the database?
Discourse on local pc
Error while importing topics from Flarum (users, groups import OK)
Unable to Install Discourse for development
Flarum To Discourse Migration
Installing Plugins in Discourse Development Install
Beginners Guide to Install Discourse on macOS for Development
Calling out for Testers
Problem in development Installation
Developing on the mobile version of Discourse
Can't build Discourse on Ubuntu 20.10
Errno::EACCES: Permission denied on new Ubuntu development setup
Problem in development Installation
Importing / migrating MyBB to Discourse
Docker in VMWare - How to access to Discourse
How can I make my own Discourse plugins?
Beginners Guide to Install Discourse on Windows 10 for Development
What is the latest recommended workflow for local development? (Ubuntu 16.04)
What is the latest recommended workflow for local development? (Ubuntu 16.04)
How to customize the Discourse app using docker container?
Update PhantomJS to latest for Ubuntu dev guide?
A check for updates has not been performed lately. Ensure sidekiq is running
How to fix bundler executable conflicts in the `techAPJ/install-rails` script?
Ubuntu development install: Permission denied @ apply2files
Install discourse on localhost
Trouble getting a top level page to Ember
Formal german available?
Any interest in Podman?
Rake aborted message is showing when installing vagrant development
Where is the db connection information discourse?
How to install the bootsnap gem?
Google Groups Import Script Fails (Due to Invalid Browser)
MailCatcher not catching email
Migrating from GetSatisfaction to Discourse
State of disqus to discourse importer
Connecting to Droplet
Connecting to Droplet
Migrating from bbPress WordPress plugin to Discourse
Beginners Guide to Install Discourse on Windows 10 for Development
Install and import Mysql on the development environment
Can't uninstall on Ubuntu 18.04
Migrating to Discourse from another Forum software
How to install Discourse on windows
Share your Discourse dev setup
Discourse running very slow on local machine
Override profile background via SSO
Can't find the Discourse folder inside virtual box via ssh
Importing MyBB database to Discourse
How to install Discourse on windows

If you are on Windows 10/11 WSL 2, curious why you haven’t used the docker install? It’s much less fussy and easier to maintain.

1 Like

I followed the Windows/Ubuntu guides but have to admit I was put off by the Docker install

:x: Cons: Will be slightly slower than the native dev environment on Ubuntu …

I will take your advice and try the Docker install.

1 Like

4 posts were split to a new topic: Notes about Installing Discourse on Ubuntu 20.04

I added this section to the OP as some error on my laptop required an OS reset and POP! OS decided that I wanted the latest version and not the one that I’d installed. If you’re using Ubuntu 22.04 I’d recommend using the docker development at least until this issue gets into the pipeline.

1 Like

I’m following these instructions (but on Arch Linux, not Ubuntu), and I’m trying to run the test suite:

When I do, I get about 10 strange “directory is already being watched” errors

Press [ENTER] to stop the current run
Running Rspec: spec
        ** ERROR: directory is already being watched! **

        Directory: /home/john/development/discourse/app/assets/javascripts/node_modules/discourse

        is already being watched through: /home/john/development/discourse/app/assets/javascripts/discourse

        MORE INFO:

Then the command gives the following output:

An error occurred while loading ./spec/integrity/i18n_spec.rb.
Failure/Error: english_yaml = YAML.load_file(english_path)["en"]

  Unknown alias: datetime_formats
# ./spec/integrity/i18n_spec.rb:65:in `block (2 levels) in <main>'
# ./spec/integrity/i18n_spec.rb:64:in `each'
# ./spec/integrity/i18n_spec.rb:64:in `block in <main>'
# ./spec/integrity/i18n_spec.rb:23:in `<main>'

Finished in 0.00011 seconds (files took 19.02 seconds to load)
0 examples, 0 failures, 1 error occurred outside of examples

And then it hangs. If I press <enter>, it responds:

No specs have failed yet! Aborting anyway

But it doesn’t actually exit until I explicitly kill it (<Ctrl-C>). Does anyone have thoughts on what might be going on here?

It could be a good thing to add explicitly that the steps in the first post are for Ubuntu 18 instead of writing here and there “if you need to install on Ubuntu 20 see these messages”, “if you intend to install Discourse on Ubuntu 22, you may need additional steps…”.

I tried on all these 3 Ubuntu versions to see how it would go and followed the fixed guidelines and advice. Ubuntu 18 is the only version where I didn’t encounter any issue.